
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html itemscope itemtype="http://schema.org/Article" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="Content-Language" content="en_US,es_US" />
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">
<meta name="robots" content="index, follow">
<meta name="GOOGLEBOT" content="index, follow" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" type="image/png" href="/favicon.png" />
<meta name="keywords" content="
		Dangerous Minds, Dangerous, Minds, Richard Metzger, Richard, Metzger
	">
<meta name="description" content="
		
&nbsp;
Charles Manson wasn&#8217;t the only rock &amp; roll cult leader. As you may have learned from watching the Paramount Network&#8217;s new miniseries Waco, David Koresh of the Branch Davidians was also known to pick up the axe from time to time&#8230;

In an era plagued by gun violence and incessant mass murders, the siege at Waco remains to be one of the most memorable shootouts in American history. As several sources have depicted the tragedy, the situation at Mount Carmel could have been handled more delicately by the ATF and the FBI, who conclusively relied on force...
	">
<meta property="fb:pages" content="101990813189245" />
<meta property="fb:admins" content="673589707,678462407" />
<meta property="fb:app_id" content="163794530937231" />
<title>
		&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh
		
		 |  
		Dangerous Minds
	</title>
<meta property="article:author" content="" />
<link rel="canonical" href="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh" />

<meta property="fb:app_id" content="132502743566989" />
<meta property="og:site_name" content="DangerousMinds" />
<meta property="og:type" content="article" />
<meta property="article:section" content="Dangerous Minds" />
<meta property="og:title" content="&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh" />

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@DangerMindsBlog">
<meta name="twitter:title" content="&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh">
<meta name="twitter:url" content="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh">
<meta name="twitter:description" content="
&nbsp;
Charles Manson wasn&#8217;t the only rock &amp; roll cult leader. As you may have learned from watching the Paramount Network&#8217;s new miniseries Waco, David Koresh of the Branch Davidians was also known to pick up the axe from time to time&#8230;

In an era plagued by gun...">
<meta name="twitter:creator" content="@DangerMindsBlog">
<meta name="twitter:domain" content="https://dangerousminds.net/">
<meta property="og:url" content="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh" />
<meta property="article:published_time" content="2018-04-13" />
<meta property="article:modified_time" content="2018-04-11" />
<meta property="og:image" content="https://dangerousminds.net/content/uploads/images/_framed/KoreshSocial-original-750-410.jpg" />
<meta name="twitter:image" content="https://dangerousminds.net/content/uploads/images/_framed/KoreshSocial-original-750-410.jpg?1523627280" />
<meta name="twitter:image:src" content="https://dangerousminds.net/content/uploads/images/_framed/KoreshSocial-original-750-410.jpg?1523627280" />
<meta name="twitter:image:width" content="" />
<meta name="twitter:image:height" content="" />
<meta itemprop="image" content="https://dangerousminds.net/content/uploads/images/_framed/KoreshSocial-original-750-410.jpg /">
<meta property="og:description" content="
&nbsp;
Charles Manson wasn&#8217;t the only rock &amp; roll cult leader. As you may have learned from watching the Paramount Network&#8217;s new miniseries Waco, David Koresh of the Branch Davidians was also known to pick up the axe from time to time&#8230;

In an era plagued by gun violence and incessant mass murders, the siege at Waco remains to be one of the most memorable shootouts in American history. As several sources have depicted the tragedy, the situation at Mount Carmel could have been handled more delicately by the ATF and the FBI, who conclusively relied on force as a method of negotiation. What began as a federal search warrant for a suspected cache of illegal weapons, erupted quite literally into a gun battle between religious cult zealots and the United States government. The standoff lasted 51 days, until the iconic conclusion on April 19th, 1993, when a tear gas attack by the FBI prompted a fire that would engulf the Mount Carmel Center. By the close of the standoff, a total of 76 people would die&#8212;including leader David Koresh.
&nbsp;

&nbsp;
The Branch Davidians arose in 1955 from a rupture within the Shepherd&#8217;s Rod, a derivative of the Seventh-day..." />

<meta itemprop="name" content="&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh">
<meta itemprop="description" content="
&nbsp;
Charles Manson wasn&#8217;t the only rock &amp; roll cult leader. As you may have learned from watching the Paramount Network&#8217;s new miniseries Waco, David Koresh of the Branch Davidians was also known to pick up the axe from time to time&#8230;

In an era plagued by gun violence and incessant mass murders, the siege at Waco remains to be one of the most memorable shootouts in American history. As several sources have depicted the tragedy, the situation at Mount Carmel could have been handled more delicately by the ATF and the FBI, who conclusively relied on force as a method of negotiation. What began as a federal search warrant for a suspected cache of illegal weapons, erupted quite literally into a gun battle between religious cult zealots and the United States government. The standoff lasted 51 days, until the iconic conclusion on April 19th, 1993, when a tear gas attack by the FBI prompted a fire that would engulf the Mount Carmel Center. By the close of the standoff, a total of 76 people would die&#8212;including leader David Koresh.
&nbsp;

&nbsp;
The Branch Davidians arose in 1955 from a rupture within the Shepherd&#8217;s Rod, a derivative of the Seventh-day...">
<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	
	  ga('create', 'UA-9352520-1', 'dangerousminds.net');
	  ga('require', 'displayfeatures');
	  ga('require', 'linkid', 'linkid.js');
	  
	ga('send', 'pageview', {
		'dimension2': "Bennett Kogon",
		'dimension3': '2018-April'
	});
	
	</script>
<script>
    window.fbAsyncInit = function() {
        FB.init({
            appId      : '163794530937231',
            xfbml      : true,
            version    : 'v2.10'
        });

        FB.AppEvents.logPageView();

    };
    (function(d, s, id){
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) {return;}
        js = d.createElement(s); js.id = id;
        js.src = "https://connect.facebook.net/en_US/sdk.js";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));
</script>
<link href="https://fonts.googleapis.com/css?family=Oswald:400,500,700" rel="stylesheet">
<link href="https://cdn-images.mailchimp.com/embedcode/classic-081711.css" rel="stylesheet" type="text/css">
<link rel='stylesheet' type='text/css' media='all' href='/content/css/default.css?i=1' />
<link rel='stylesheet' type='text/css' media='all' href='/content/css/hamburgers.css?i=1' />
<link rel='stylesheet' type='text/css' media='all' href='/content/css/styles.css?i=1' />
<link rel="stylesheet" href="/content/css/social-share-kit.css?i=1" type="text/css">
<link rel="stylesheet" href="/content/css/responsive.css?i=1" type="text/css">
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://feeds.feedburner.com/dangerousminds/dot/net" />
<link rel="alternate" type="application/atom+xml" title="Atom" href="https://dangerousminds.net/site/atom" />

<script type="text/javascript">
	var _sf_async_config={uid:6248,domain:"dangerousminds.net"};
	
	(function(){
	  function loadChartbeat() {
	    window._sf_endpt=(new Date()).getTime();
	    var e = document.createElement('script');
	    e.setAttribute('language', 'javascript');
	    e.setAttribute('type', 'text/javascript');
	    e.setAttribute('src',
	       (("https:" == document.location.protocol) ? "https://s3.amazonaws.com/" : "http://") +
	       "static.chartbeat.com/js/chartbeat.js");
	    document.body.appendChild(e);
	  }
	  var oldonload = window.onload;
	  window.onload = (typeof window.onload != 'function') ?
	     loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();
	
</script>

<script>
    //Set these three variables

    //The skin links out to this URL:
    var dmskin_linkout = "https://Rhino.lnk.to/ForeverChanges50";

    //SKIN START TIME: year, month, day, hour, min, sec, timezone offset
        //For timezone offset: -4 is Eastern Daylight Savings Time (Spring through mid-Fall), -5 is Eastern Standard Time (Mid-fall thorugh winter)
        //Ex: Begins Midnight April 2, 2018 is: 2018, 4, 2, 0, 0, 0, -4
    var dmskin_started_array = [2018, 4, 6, 0, 0, 0, -4];

    //SKIN END TIME: year, month, day, hour, min, sec, timezone offset
        //Ex: Ends Midnight April 3, 2018 is: 2018, 4, 3, 0, 0, 0, -4
    var dmskin_ended_array = [2018, 4, 7, 0, 0, 0, -4];


    //This options lets you show the skin in staging.  It also allows the date codes above to be set in place.
    //This way you can preview in staging in advance, while also allows production to automatically adjust
    var dmskin_show_in_staging = true;
</script>

<style>
    @media only screen and (min-width: 1025px) {
        body.bannertime,
        .bannertime #socialbar {
            background-color: transparent;
        }
        .bannertime #Desktop_Leaderboard_outer {
             background-color: transparent;
        }
        .bannertime #ggskin {
            background-repeat: no-repeat;
            width: 100%;
            height: 1300px; /*ok if taller */
            display: block;
            background-position: top center;
            position: fixed;
            left:0px;

            /* YOU WILL PROBABLY JUST ADJUST THIS SMALL PART HERE, BUT YOU CAN ALSO DO MORE ABOVE */
            top: 26px;
            background-color: #ffffff;
            background-image: url('/content/images/skins/skin_20180405_love.jpg');
        }
    }
</style>

<script type="text/javascript" src="//htl.bid/build/bidder-dangerous-minds.js"></script>
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>
<script>
function createSkin(htmlStr) {
    var frag = document.createDocumentFragment(),
        temp = document.createElement('div');
    temp.innerHTML = htmlStr;
    while (temp.firstChild) {frag.appendChild(temp.firstChild);}
    return frag;
}
Date.prototype.addHours = function(h) {
    this.setTime(this.getTime() + (h*60*60*1000));
    return this;
}
var ee_baseurl = "{base_url}";
function scIsDateReached(yy, mm, dd, h, m, s,hours_timezone_adjust) {
    if (yy===null) yy=1970;
    if (mm===null) mm=1;
    if (dd===null) dd=1;
    if (h===null) h=0;
    if (m===null) m=0;
    if (s===null) s=0;
    mm -=1; //month starts at 0

    var od = new Date(yy, mm, dd,h,m,s);
    var cd = new Date();

    if(hours_timezone_adjust==="undefined" || hours_timezone_adjust===undefined) {hours_timezone_adjust="";}

    if (hours_timezone_adjust !== "") {
        var offset = cd.getTimezoneOffset();
        offset = -1 * (offset/60);  //negative is east of GMT, positive is west of GMT
        offset = offset-hours_timezone_adjust; //our adjust uses the regular with negative for west of GMT
        //alert(offset);
        //8 is LA, 7 without daylight savings

        od.addHours(offset);
    }

    //alert(od);
    console.log("Current Date: " + cd);
    console.log("Checkign for Date: " + od);
    if (cd >= od) {
        var ret = true;
    } else {
        var ret = false;
    }
    return ret;
}


//CHANGE THESE

///


//httphost
var skin_show_override = false
if (dmskin_show_in_staging) {
    var thehost = window.location.hostname;
    var is_staging = false;
    if (thehost.indexOf('stage.dangerousminds.net')>-1) {is_staging=true;}
    if (is_staging) {
        console.log('====STAGING OVERRIDE ON');
        skin_show_override = true;//set to true to always show skin, useful in staging
    }
}
var skin_show = false;


var dmskin_started = scIsDateReached(
    dmskin_started_array[0],
    dmskin_started_array[1],
    dmskin_started_array[2],
    dmskin_started_array[3],
    dmskin_started_array[4],
    dmskin_started_array[5]
);
var dmskin_ended = scIsDateReached(
    dmskin_ended_array[0],
    dmskin_ended_array[1],
    dmskin_ended_array[2],
    dmskin_ended_array[3],
    dmskin_ended_array[4],
    dmskin_ended_array[5]
);
if (dmskin_ended ) {
    console.log('====SKIN END');
    skin_show = false;
    //set skin_show_override to false, that way staging will automatically shut off after the date too
    skin_show_override=false;
} else if (dmskin_started ) {
    console.log('====SKIN ON');
    skin_show = true;
} else {
    console.log('====SKIN NOT START');
    skin_show = false;
}
if (skin_show_override) {skin_show=true;}
if (skin_show) {
    setTimeout(function () {
        var fragment = createSkin('<a id="ggskin" href="' + dmskin_linkout + '" target="_blank"></a>');
        document.body.insertBefore(fragment, document.body.childNodes[0]);
        $('body').addClass('bannertime');
    }, 100);

    var tag = document.createElement('script');
    tag.src = "https://ad.doubleclick.net/ddm/adj/N3926.678838DANGEROUSMINDS.NET/B20355325.206252477;sz=1x1;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?";
    var firstScriptTag = document.getElementsByTagName('script')[0];
    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
}
</script>
<script type="text/javascript" src="//code.jquery.com/jquery-1.11.3.min.js"></script>
<script type="text/javascript" src="/content/js/site.js?i=1"></script>

<script class="kxct" data-id="Jxmq4_BT" data-timing="async" data-version="3.0" type="text/javascript">
	window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
	(function(){
	var k=document.createElement('script');k.type='text/javascript';k.async=true;
	k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/Jxmq4_BT.js';
	var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
	}());
	</script>

<script class="kxint" type="text/javascript">
	window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
	(function(){
		function retrieve(n){
			var m, k='kx'+n;
			if (window.localStorage) {
				return window.localStorage[k] || "";
			} else if (navigator.cookieEnabled) {
				m = document.cookie.match(k+'=([^;]*)');
				return (m && unescape(m[1])) || "";
			} else {
			  return '';
			}
		}
		Krux.user = retrieve('user');
		Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
	});
	</script>

<script>
		function getVembaSelector(style) { 
			var sel = "";
			if (style==="in-paragraphs-4") { 
				var sel1 = '#blog .entry:nth-child(1) #text';
		        if ($(sel1).length===0) { 
			        sel1 = '#blog .entry #text';
			    }
			    
			    var sel2 = 'p:nth-child(4)';
			    if ($(sel1 + ' ' + sel2).length===0) { 
				    sel2 = 'p:nth-child(3)';
					if ($(sel1 + ' ' + sel2).length===0) { 
						sel2 = 'p:nth-child(2)';    
						if ($(sel1 + ' ' + sel2).length===0) { 
							sel2 = 'p:nth-child(1)';   	
							if ($(sel1 + ' ' + sel2).length===0) { 
								sel2 = 'p'; 
							}
						}
					}
				}
				sel = sel1 + ' ' + sel2;
			} else if (style==="in-paragraphs-3") { 
				var sel1 = '#blog .entry:nth-child(1) #text';
		        if ($(sel1).length===0) { 
			        sel1 = '#blog .entry #text';
			    }
			    
			    var sel2 = 'p:nth-child(3)';
			    if ($(sel1 + ' ' + sel2).length===0) { 
				    sel2 = 'p:nth-child(2)';
					if ($(sel1 + ' ' + sel2).length===0) { 
						sel2 = 'p:nth-child(1)';   	
						if ($(sel1 + ' ' + sel2).length===0) { 
							sel2 = 'p'; 
						}						
					}
				}
				sel = sel1 + ' ' + sel2;
			} else if (style==="in-paragraphs-2") { 
				var sel1 = '#blog .entry:nth-child(1) #text';
		        if ($(sel1).length===0) { 
			        sel1 = '#blog .entry #text';
			    }
			    
			    //var sel2 = 'p:nth-child(3)';
			    //if ($(sel1 + ' ' + sel2).length===0) { 
				    var sel2 = 'p:nth-child(2)';
					if ($(sel1 + ' ' + sel2).length===0) { 
						sel2 = 'p:nth-child(1)';   	
						if ($(sel1 + ' ' + sel2).length===0) { 
							sel2 = 'p'; 
						}						
					}
				//}
				sel = sel1 + ' ' + sel2;
            } else if (style==="in-paragraphs-1") {
                var sel1 = '#blog .entry:nth-child(1) #text';
                if ($(sel1).length===0) {
                    sel1 = '#blog .entry #text';
                }

                //var sel2 = 'p:nth-child(3)';
                //if ($(sel1 + ' ' + sel2).length===0) {
                var sel2 = 'p:nth-child(1)';
				if ($(sel1 + ' ' + sel2).length===0) {
					sel2 = 'p';
				}
                //}
                sel = sel1 + ' ' + sel2;
	        } else if (style==="between-posts") { 
		        sel = "#blog .entry:nth-child(1)";
		        if ($(sel).length===0) { 
			    	sel = "#blog .entry"; 
			    }
		    }
            //console.log ( style + ' : ' + sel);
	        return sel;
		}
	</script>
<script>
		$( document ).ready(function() {

            //teads
			 var thehtml = "<div style='padding:10px 0px' id='teadsInread'>";
            thehtml += "<script>googletag.cmd.push(function(){googletag.display('teadsInread');});</";
            thehtml += "script>";
            thehtml += "</div>";

            var sel = getVembaSelector("in-paragraphs-3");
            var did_it = false;
            $( sel ).each(function( index ) {
                if (did_it===false) {
                    $(thehtml).insertAfter( this );
                    did_it=true;
                    //console.log ( this);
                }
            });


		    //vice
		    var thehtml = '<div style="font-family:Helvetica,sans-serif;font-weight:bold;text-transform:uppercase;font-size:15px;padding-top:15px;padding-bottom:9px;border-bottom:1px solid black;margin-bottom:17px;">From our partners at Vice</div>';
            //thehtml += '<iframe width="465" height="262" src="https://video.vice.com/en_us/embed/5aa16273f1cdb32b3a3df7d1?autoplay=1&continuous=0&volume=0" frameBorder="0" scrolling="no" allowfullscreen></';
            //thehtml += 'iframe>';
		    thehtml += "<script type='text/javascript' src='https://videos-by.vemba.io/v2/placements/25989.js'></";
	        thehtml += 'script>';
	        thehtml += '<div style="border-bottom:1px solid #000;margin-bottom:25px;padding-bottom:5px">&nbsp;</div>';
	        
	        var sel = getVembaSelector("in-paragraphs-2");
	        var did_it = false;
			$( sel ).each(function( index ) {
				if (did_it===false) { 
					$(thehtml).insertAfter( this );
					did_it=true;
					//console.log ( this);
				}
			});
			

	        
		});
		</script>
<script>
		$( document ).ready(function() {
			var thehtml = "<div style='padding:10px 0px;text-align:center;' id='Mobile_MedRec_2'>";
			thehtml += "<script>googletag.cmd.push(function(){googletag.display('Mobile_MedRec_2');});</";
			thehtml += "script>";
			thehtml += "</div>";
		
			var sel = getVembaSelector("in-paragraphs-2");
			var did_it = false;
			$( sel ).each(function( index ) {
				if (did_it===false) { 
					$(thehtml).insertAfter( this );
					did_it=true;
					//console.log ( this);
				}
			});
		});
		</script>
</head>
<body>
<div id="fb-root"></div>
<script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script>
<div id="mobile_top"><div id="mobile_top_inner">
<div id="mobile_top_hamburger">
<button class="hamburger hamburger--spin" type="button">
<span class="hamburger-box">
<span class="hamburger-inner"></span>
</span>
</button>
</div>
<div id="mobile_top_logo">
<a href="https://dangerousminds.net/"><img src="https://dangerousminds.net/content/images/site_elements/dmlogo.png" /></a>
</div>
</div></div>
<div id="mobile_nav"><div id="mobile_nav_inner">
<div id="mobile_nav_overlay" class="hidden">
<ul>
<li><a href="https://dangerousminds.net/"><span class="header_nav_txt">HOME</span></a></li>
<li><a href="https://dangerousminds.net/articles"><span class="header_nav_txt">ARTICLES</span></a></li>
<li><a href="https://dangerousminds.net/categories"><span class="header_nav_txt">TOPICS</span></a></li>
<li><a href="https://dangerousminds.net/archives"><span class="header_nav_txt">ARCHIVES</span></a></li>
<li><a href="https://dangerousminds.net/contributors"><span class="header_nav_txt">CONTRIBUTORS</span></a></li>
<li><a href="https://dangerousminds.net/advertising"><span class="header_nav_txt">ADVERTISE</span></a></li>
<li><a href="https://dangerousminds.net/suggest"><span class="header_nav_txt">CONTACT US</span></a></li>
<li class="search">
<form name="search_form" class="formclass" method="post" action="https://dangerousminds.net/">
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="107" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="e186c58b18e38556591b00c56fc4f70f4e441120" />
</div>
<input type="text" name="keywords" onFocus="this.value=''" value="SEARCH" class="sbinput" size="18" maxlength="100" onUnfocus="send()" />
</form>
</li>
</ul>
</div>
</div></div>
<div id="socialbar">
<span class="socialcontent">
<span id="socialcontent_txt_follow" class="socialcontent_txt">FOLLOW US ON:</span>
<a class="socialcontent_icon" href="https://www.facebook.com/pages/Dangerous-Minds/101990813189245" target="_blank" class="smbuttons">
<img src="https://dangerousminds.net/content/images/site_elements/newfb.png" />
</a>
<a class="socialcontent_icon" href="https://twitter.com/#!/DangerMindsBlog" target="_blank" class="smbuttons">
<img src="https://dangerousminds.net/content/images/site_elements/newtwitter.png" />
</a>
<a class="socialcontent_icon" href="https://pinterest.com/dangerousminds/" target="_blank" class="smbuttons">
<img src="https://dangerousminds.net/content/images/site_elements/newpinterest.png" />
</a>

<a class="socialcontent_icon" href="https://www.reddit.com/domain/dangerousminds.net" target="_blank" class="smbuttons">
<img src="https://dangerousminds.net/content/images/site_elements/newreddit.png" />
</a>

<a class="socialcontent_icon" href="https://feeds.feedburner.com/dangerousminds/dot/net" target="_blank" class="smbuttons">
<img src="https://dangerousminds.net/content/images/site_elements/newrss.png" />
</a>
<span style="float:right; position:relative;display:block;">
<span id="ournewsletter">
<div id="ournewsletter_title">GET THE NEWSLETTER</div>

<div id="mc_embed_signup">
<form action="https://dangerousminds.us5.list-manage1.com/subscribe/post?u=d2b6609cf4426d73cc323aab7&amp;id=ecada8d328" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank">
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address </label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div>
<div class="clear">
<center><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></center></div>
</form>
</div>
</span>
<form name="search_form" class="formclass" method="post" action="https://dangerousminds.net/">
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="107" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="e186c58b18e38556591b00c56fc4f70f4e441120" />
</div>
<input type="text" name="keywords" onFocus="this.value=''" value="SEARCH" class="sbinput" size="18" maxlength="100" onUnfocus="send()" />
</form>
<span style="display:block;width:101px;height:30px;position:relative;float:right;margin-right:10px;margin-left:10px;">
<a href="https://dangerousminds.net/suggest">
<span id="socialcontent_txt_contact" class="socialcontent_txt">CONTACT US</span>
</a>
</span>
</span>
</span>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "8568956" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=8568956&cv=2.0&cj=1" />
</noscript>

<div id="wrapper">
<div id="ad728">
<center>

<div id='Desktop_Leaderboard_outer'><div id='Desktop_Leaderboard'>
<script type='text/javascript'>
    googletag.cmd.push(function() {googletag.display('Desktop_Leaderboard');});
  </script>
</div></div>
<div id='Mobile_Leaderboard'>
<script type='text/javascript'>
    googletag.cmd.push(function() {googletag.display('Mobile_Leaderboard');});
  </script>
</div>

</center>
<div class="spacer"></div>
</div>
<div id="header">
<a href="https://dangerousminds.net/"><div id="homelogo"></div></a>
<ul>
<li><a href="https://dangerousminds.net/advertising"><span class="header_nav_txt">ADVERTISE</span></a></li>
<li><a href="https://dangerousminds.net/articles"><span class="header_nav_txt">ARTICLES</span></a></li>
<li><a href="https://dangerousminds.net/"><span class="header_nav_txt">HOME</span></a></li>
<li><a href="https://dangerousminds.net/archives"><span class="header_nav_txt">ARCHIVES</span></a></li>
<li><a href="https://dangerousminds.net/contributors"><span class="header_nav_txt">CONTRIBUTORS</span></a></li>
<li><span class="header_nav_txt header_nav_txt_topics">TOPICS</span>
<ul>
<li><a href="https://dangerousminds.net/categories/category/a_girls_best_friend_is_her_guitar"><span class="header_subnav_txt">A girl's best friend is her guitar</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/activism"><span class="header_subnav_txt">Activism</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/advertising"><span class="header_subnav_txt">Advertising</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/advertorial"><span class="header_subnav_txt">Advertorial</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/american-style_republican_christianity"><span class="header_subnav_txt">American-style (Republican) Christianity</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/Amusing"><span class="header_subnav_txt">Amusing</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/animals"><span class="header_subnav_txt">Animals</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/animation"><span class="header_subnav_txt">Animation</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/Art"><span class="header_subnav_txt">Art</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/Belief"><span class="header_subnav_txt">Belief</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/Books"><span class="header_subnav_txt">Books</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/class_war"><span class="header_subnav_txt">Class War</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/crime"><span class="header_subnav_txt">Crime</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/current_events"><span class="header_subnav_txt">Current Events</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/dance"><span class="header_subnav_txt">Dance</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/design"><span class="header_subnav_txt">Design</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/drugs"><span class="header_subnav_txt">Drugs</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/economy"><span class="header_subnav_txt">Economy</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/fashion"><span class="header_subnav_txt">Fashion</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/featured"><span class="header_subnav_txt">Featured</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/feminism"><span class="header_subnav_txt">Feminism</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/food"><span class="header_subnav_txt">Food</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/video_games"><span class="header_subnav_txt">Games</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/hip-hop"><span class="header_subnav_txt">Hip-hop</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/history"><span class="header_subnav_txt">History</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/hysteria"><span class="header_subnav_txt">Hysteria</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/idiocracy"><span class="header_subnav_txt">Idiocracy</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/kooks"><span class="header_subnav_txt">Kooks</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/literature"><span class="header_subnav_txt">Literature</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/media"><span class="header_subnav_txt">Media</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/movies"><span class="header_subnav_txt">Movies</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/music"><span class="header_subnav_txt">Music</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/occult"><span class="header_subnav_txt">Occult</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/one-hit_wonders"><span class="header_subnav_txt">One-hit wonders</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/politics"><span class="header_subnav_txt">Politics</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/pop_culture"><span class="header_subnav_txt">Pop Culture</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/punk"><span class="header_subnav_txt">Punk</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/queer"><span class="header_subnav_txt">Queer</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/r.i.p"><span class="header_subnav_txt">R.I.P.</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/race"><span class="header_subnav_txt">Race</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/science_tech"><span class="header_subnav_txt">Science/Tech</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/sex"><span class="header_subnav_txt">Sex</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/sports"><span class="header_subnav_txt">Sports</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/Stupid_or_Evil"><span class="header_subnav_txt">Stupid or Evil?</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/superstar"><span class="header_subnav_txt">Superstar</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/television"><span class="header_subnav_txt">Television</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/the_wrong_side_of_history"><span class="header_subnav_txt">The wrong side of history</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/they_hate_us_for_our_freedom"><span class="header_subnav_txt">They hate us for our freedom</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/thinkers"><span class="header_subnav_txt">Thinkers</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/u.s.a"><span class="header_subnav_txt">U.S.A.!!!</span></a></li>
<li><a href="https://dangerousminds.net/categories/category/unorthodox"><span class="header_subnav_txt">Unorthodox</span></a></li>
</ul>
</li>
</ul>
</div>

<div id="blog">
<div id="addspace"></div>
<span class="googlepluslink"><a href="" rel="author">Google+</a></span>
<div class="entry  "><div class="entry_inner">
<div id="entrytitle2"><div id="entrytitle_inner">
&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh
</div></div>
<div id="clear"></div>
<div id="catinfo">
<div class="l l_date">04.13.2018</div>
<div class="l l_time">09:48 am</div>
<div class="l l_topics">Topics:</div>
<div class="l l_topics_group">
<div class="l l_topics_group_l"><a href="https://dangerousminds.net/categories/category/history">History</a></div>
<div class="l l_topics_group_l"><a href="https://dangerousminds.net/categories/category/hysteria">Hysteria</a></div>
<div class="l l_topics_group_l"><a href="https://dangerousminds.net/categories/category/music">Music</a></div>
<div class="l l_topics_group_l"><a href="https://dangerousminds.net/categories/category/u.s.a">U.S.A.!!!</a></div>
</div>
<div class="l l_tags">Tags:</div>
<div class="l l_tags_group">
<div class="l l_tags_group_l"><a href="https://dangerousminds.net/tag/cults">cults</a></div>
<div class="l l_tags_group_l"><a href="https://dangerousminds.net/tag/Waco">Waco</a></div>
<div class="l l_tags_group_l"><a href="https://dangerousminds.net/tag/Branch-Davidians">Branch Davidians</a></div>
<div class="l l_tags_group_l"><a href="https://dangerousminds.net/tag/David-Koresh">David Koresh</a></div>
</div>
<span class="socialImageFallback">
<img src="https://dangerousminds.net/content/uploads/images/_framed/KoreshSocial-original-750-410.jpg" alt="&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh" class="socialImage" />
</span>
</div>
<div id="text">
<p><img src="/content/uploads/images/made/content/uploads/images/75_465_262_int.jpeg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/75.jpeg" width="465" height="262" /><br />
&nbsp;<br />
Charles Manson wasn&#8217;t the only rock &amp; roll cult leader. As you may have learned from watching the Paramount Network&#8217;s new miniseries <em>Waco</em>, David Koresh of the Branch Davidians was also known to pick up the axe from time to time&#8230;</p>
<p>In an era plagued by gun violence and incessant mass murders, the siege at Waco remains to be one of the most memorable shootouts in American history. As several sources have depicted the tragedy, the situation at Mount Carmel could have been handled more delicately by the ATF and the FBI, who conclusively relied on force as a method of negotiation. What began as a federal search warrant for a suspected cache of illegal weapons, erupted quite literally into a gun battle between religious cult zealots and the United States government. The standoff lasted 51 days, until the iconic conclusion on April 19th, 1993, when a tear gas attack by the FBI prompted a fire that would engulf the Mount Carmel Center. By the close of the standoff, a total of 76 people would die&#8212;including leader David Koresh.<br />
&nbsp;<br />
<img src="/content/uploads/images/made/content/uploads/images/david-koresh-right-perry-jones-left-and-david-jones_465_339_int.jpg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/david-koresh-right-perry-jones-left-and-david-jones.jpg" width="465" height="339" /><br />
&nbsp;<br />
The Branch Davidians arose in 1955 from a rupture within the Shepherd&#8217;s Rod, a derivative of the Seventh-day Adventist Church. The original sect was led by self-proclaimed prophet Victor Houteff who, twenty years prior, had established its headquarters at the Mount Carmel Center near Waco, Texas. When Houteff unexpectedly passed, many disagreements within the church brought about splinter groups like the aforementioned Branch Davidians, now led by the quasi-prophet, Benjamin Roden. Similar to the doctrines preached in the Shepherd&#8217;s Rod, the Branch Davidians believed they were living in the final period of Biblical prophecies, right before absolute judgement and the second coming of Christ. </p>
<p>David Koresh joined the Branch Davidians in 1981. Known then as Vernon Howell, the Koresh of his early-twenties seduced Lois Roden, the now-widowed leader of the commune, who was in her late sixties. The following year, Koresh declared himself to be the true prophet of the group and relayed that he had been instructed by God to bear a child with Lois, who would be considered the &#8220;Chosen One.&#8221; Upon Lois&#8217; death, her son George Roden took over leadership of the Branch Davidians and exiled Koresh from the compound in fear of his rising influence. This was up until 1989, when Roden was convicted of murdering follower Wayman Dale Adair because he was believed to have been sent by Koresh. The former Vernon Howell then changed his name to that of celestial significance (after King David and &#8220;Koresh&#8221; being the Biblical name of <a href="https://en.wikipedia.org/wiki/Cyrus_the_Great">Cyrus the Great</a>) and he, along with his followers, raised enough money to buy-back Mount Carmel from the US government. From that moment forward, David Koresh became the final prophet of the Branch Davidians.<br />
&nbsp;<br />
<img src="/content/uploads/images/made/content/uploads/images/David_Koresh_and_Branch_Davidians-_Internet_Archive-_from_Report_of_the_Department_of_the_Treasury_on_the_Bureau_of_Alcohol,_Tobacco,_and_Firearms_investigation_of_Vernon_Wayne_Howell_also_known_as_David_Koresh_465_600_int.jpg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/David_Koresh_and_Branch_Davidians-_Internet_Archive-_from_Report_of_the_Department_of_the_Treasury_on_the_Bureau_of_Alcohol,_Tobacco,_and_Firearms_investigation_of_Vernon_Wayne_Howell_also_known_as_David_Koresh.jpg" width="465" height="600" /><br />
<em>David and the Bros</em><br />
&nbsp;<br />
Besides stockpiling weaponry, Koresh lived above the law through his teachings of the &#8220;New Light Message.&#8221; The men who practiced at Mount Carmel, even those who had committed alongside their wives, were to now lead a celibate life. The women, however, would be sexually and reproductively committed to Koresh, who insisted upon a harem of available women known as the &#8220;House of David.&#8221; The reasoning was, you guessed it, because of God&#8217;s commandments, that Koresh was to hold &#8220;spiritual weddings&#8221; with any woman that their Lord had instructed him to. Many of the women of the Branch Davidian cult became wives of Koresh, several of which had already been legally married&#8212;or were underage. At least one follower in particular, Michelle Jones, had her first child with Koresh when she was fourteen years old. The two had begun a sexual relationship years prior while her older sister, Rachel Jones-Koresh, remained the prophet&#8217;s only legal wife (whom she also married when she was fourteen). The parents of Michelle and Rachel Jones had been lifelong Branch Davidians and had given David permission to bed &amp; wed their daughters.</p>
<p>It is believed that Koresh had fathered over fifteen children with the women of the group. He expected his children to be perfect and that they would eventually become the ruling elders after the apocalypse and the alleged second coming of Christ. The ideology of the Branch Davidians was heavily focused on Judgement Day and it was Koresh&#8217;s prophesy that only he could open the &#8220;Seven Seals&#8221; as foretold in the New Testament&#8217;s Book of Revelation. This action would bring about the calamitous end of times, wherefore those devoted &#8220;Koreshians&#8221; would be led into the heavens by their divine leader. Koresh and his followers&#8217; reaction to the standoff at Mount Carmel <em>was</em> that the Seven Seals had been opened and mankind&#8217;s decimation was upon them.<br />
&nbsp;<br />
<img src="/content/uploads/images/made/content/uploads/images/5a462dcb506af.image_465_317_int.jpg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/5a462dcb506af.image.jpg" width="465" height="317" /><br />
&nbsp;<br />
Just a day before the initial raid at Mount Carmel, the Waco Tribune ran its shocking, multi-part expose&#8217; on the cult of David Koresh titled &#8220;<a href="http://www.wacotrib.com/news/branch_davidians/sinful-messiah/the-sinful-messiah-part-one/article_eb1b96e9-413c-5bab-ba9f-425b373c5667.html">The Sinful Messiah</a>.&#8221; Among the story&#8217;s heinous depictions of child abuse, statutory rape, polygamy, paranoia, and a heavy artillery, another persona of David Koresh had also been characterized&#8212;that of a rocker. At 22 years of age, Koresh was kicked out of his mother&#8217;s Seventh-day Adventist Church in Houston for trying to marry the pastor&#8217;s daughter. An aspiring musician, Koresh then moved to Los Angeles in hopes of becoming a rock star. His attempt was considered an &#8220;utter failure,&#8221; and this is what led Koresh to Waco, Texas.</p>
<p>It could be said that David&#8217;s <a href="https://www.spin.com/featured/david-koresh-waco-texas-1993-siege-feature/">rock ambitions</a> were what led him to literally try to become Jesus Christ. Plenty of rock stars regard themselves in self-idolatry, so the career trajectory checks out. While in Waco, Koresh engaged himself in the local music scene and began booking bands at a club behind the K-Mart called Cue Sticks. Koresh would oftentimes invite local bands back to Mount Carmel for jam sessions&#8212;held sometimes late into the night. Bands would play in the main parlor of the compound, also where the altar was located and where services were conducted. For a wacko religious cult, the Branch Davidians had a comprehensive music set-up, with a vast selection of quality instruments and an elaborate sound and recording system. It was David&#8217;s intention that by interacting with musicians and those in local nightlife, that he would gain new recruits to the Church. Some were dissuaded by David&#8217;s blathering of the Seven Seals, while others, like known follower David Thibodeau, would become vital components to Koresh&#8217;s kingdom. Thibodeau met David at the Guitar Center in Hollywood and upon Koresh learning that he was a drummer, he was asked to join the Branch Davidians in Waco. Thibodeau would be the one to participate in the &#8220;mock wedding&#8221; with the underage Michelle Jones in order to cover up any suspicions of sex with minors.<br />
&nbsp;<br />
<img src="/content/uploads/images/made/content/uploads/images/koresh_rockinout_1920_465_262_int.jpg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/koresh_rockinout_1920.jpg" width="465" height="262" /><br />
<em>The Paramount Network&#8217;s depiction of David Koresh</em><br />
&nbsp;<br />
In the first episode of the Paramount Network&#8217;s series <em>Waco</em>, David and his rock band of Branch Davidians cover &#8220;My Sharona&#8221; at the local pub. In another episode, during the part of the siege when the ATF would amplify sounds of rabbits getting murdered late at night, David is able to revive their generator for ten minutes to play a cover of The Call&#8217;s &#8220;<a href="https://www.youtube.com/watch?v=272T8hZUqcs">I Still Believe</a>&#8221; (on a Flying-V guitar, mind you). Ironically, David Koresh had his own original music, and some of it is <em>actually</em> pretty good. Is it fucked up to say that it&#8217;s good? [Admit it, &#8220;<a href="https://www.youtube.com/watch?v=mpx4ODP35VQ">Look at Your Game Girl</a>&#8221; is actually pretty catchy. ]</p>
<p>None of Koresh&#8217;s music caught the public ear until after the Waco fiasco, naturally. <a href="https://www.discogs.com/David-Koresh-Voice-Of-Fire/release/2082284"><em>Voice of Fire</em></a> was a three-song CD that was released in 1993, so shortly after the standoff ended. Sandwiched in-between two religious rock tracks is an fifty-seven minute sermon conducted by David Koresh at Mount Carmel. There&#8217;s also an hour-long <a href="https://archive.org/details/davidkoresh">discography</a> of David&#8217;s music online. The collection features Koresh on the electric guitar, singing songs of religious content of great intention. And let&#8217;s not forget the track titled &#8220;<a href="https://youtu.be/on4Y43WPXXA?t=36m45s">Jesus Loves Me</a>,&#8221; with guest vocals by <em>some kid</em>. It&#8217;s definitely creepy. But, let&#8217;s remove the artist from the art and maybe there will be something there? <br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/74wmI1Qm0rk" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>David Koresh does &#8220;Mad Man in Waco&#8221;</em></p>
<p>One quick note about the song &#8220;Mad Man in Waco.&#8221; Seems pretty obvious what the subject matter would be, but Koresh actually wrote it about George Roden, his direct competition for the throne (also who killed a guy with <em>his axe</em>). In order to prove who the true messiah was, George Roden challenged Koresh to a competition to be the first person to raise the dead. Roden dug up the corpse of a woman who had died two decades prior and Koresh alerted the authorities of corpse abuse. Koresh needed proof, so he and others showed up to Mount Carmel, dubbed &#8220;Rodenville,&#8221; and a gun battle ensued (Roden had an Uzi). Can you believe there was a shootout in Waco <em>six years before</em> the ATF showed up? Speaking of shootouts, April 19th marks the 25th anniversary of the fire at Mount Carmel. It&#8217;s also the 23rd anniversary of the Oklahoma City bombing, which was a direct retaliation to what went down in Waco. <br />
&nbsp;<br />
<img src="/content/uploads/images/made/content/uploads/images/download-1-30_465_304_int.jpg" alt="" interlace="yes" class="gallery" rel="rel_24943" href="https://dangerousminds.net/content/uploads/images/download-1-30.jpg" width="465" height="304" /><br />
&nbsp;<br />
<em>Listen to the music of David Koresh below:</em><br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/MMnIDFYCn34" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>&#8220;Book of Daniel&#8221;</em><br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/aZpO8FaptzE" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>&#8220;Sheshonahim&#8221;</em><br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/pv-Me-2UqdA" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>&#8220;Waiting on You&#8221;</em><br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/sNjZFDA2vxw" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>&#8220;By the Rivers of Babylon&#8221;</em><br />
&nbsp;</p><iframe width="465" height="75" src="https://www.youtube.com/embed/Vg9LIQ7gfPs?start=18" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>&#8220;Darkness in the Light (unknown remix)&#8221;</em><br />
&nbsp;</p><iframe width="465" height="343" src="https://www.youtube.com/embed/4i7EBssLV6E" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
<p><em>BBC Panorama episode on &#8216;The Sinful Messiah&#8217; from 1993</em><br />
&nbsp;</p>
<div class="ebzNative"></div>
<p>
<em>Previously on Dangerous Minds:</em><br>
<strong><a href="https://dangerousminds.net/comments/charles_manson_superstar_the_underworld_pope_is_finally_dead._may_he_rot_in">&#8216;Charles Manson Superstar&#8217;: The underworld Pope is (finally) dead. May he rot in Hell</a></strong><br />
</p>
<div id="doubleline"></div>
</div>
<div class="posted">
<div id="posted_first_line">
<div class="posted_author">Posted by Bennett Kogon</div>
<div id="posted_seperator_1" class="posted_seperator"> | </div>
<div class="posted_date">04.13.2018</div>
<div class="posted_time">09:48 am</div>
<div id="posted_seperator_2" class="posted_seperator"> | </div>
<div class="posted_comments"><script type="text/javascript">var disqus_shortname = 'dangerminds';(function () {
            var s = document.createElement('script'); s.async = true;
            s.type = 'text/javascript';
            s.src = 'https://' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
    </script><a href="/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh#disqus_thread" data-disqus-identifier="dangerminds_24943" class="disqus-comment-link">Discussion</a></div>
</div>
<div id="singleline2"></div>
<div id="sharethisman" class="t8">
<div class="ssk-group ssk-lg ssk-count" data-url="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh" a="&#8216;Mad Man in Waco&#8217;: The haunting rock ballads of cult leader David Koresh" data-text=" ">
<a href="" class="ssk ssk-facebook"></a>
<a href="" class="ssk ssk-twitter" data-via="dangermindsblog"></a>

<a href="" class="ssk ssk-tumblr" title="Tumblr"></a>
<a href="" class="ssk ssk-pinterest" title="Pintrest"></a>
<a href="" class="ssk ssk-reddit2" title="Reddit"></a>
</div>
</div>
</div>
</div>
<div id="clear"></div>
</div>

<div class="entry"><div class="entry_inner">
<p>&nbsp;</p>
<div class="OUTBRAIN" data-src="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh" data-widget-id="TF_1" data-ob-template="DangerousMinds"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
</div></div>

<script id="mNCC" language="javascript">
			medianet_width = "600";
			medianet_height = "250";
			medianet_crid = "857156113";
			medianet_versionId = "111299"; 
			(function() {
			    var isSSL = 'https:' == document.location.protocol;
			    var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUEOMD21' + (isSSL ? '&https=1' : '');
			    document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
			})();
		</script>

<script type="text/javascript">
jQuery(function($) {
    // Debug flag
    var debugMode = false;

    // Default time delay before checking location
    var callBackTime = 100;

    // # px before tracking a reader
    var readerLocation = 150;

    // Set some flags for tracking & execution
    var timer = 0;
    var scroller = false;
    var endContent = false;
    var didComplete = false;

    // Set some time variables to calculate reading time
    var startTime = new Date();
    var beginning = startTime.getTime();
    var totalTime = 0;
    
    // Get some information about the current page
    var pageTitle = document.title;
    // send the author and and publish date as custom dimensions wiht the pageview. For all other pages the header tag is sending the pageview.
	

    // Track the aticle load
    if (!debugMode) {
        ga('send', 'event', 'Reading', 'ArticleLoaded', pageTitle, {'nonInteraction': true});  
    } else {
        alert('The page has loaded. Woohoo.');    
    };
    if (!debugMode) {
    	
        ga('send', 'event', 'Author', 'Bennett Kogon', pageTitle, {'nonInteraction': true});   
    } else {
        alert('Author Goes Here');    
    }
    
    if (!debugMode) {
        ga('send', 'event', 'Categories', 'History', pageTitle, {'nonInteraction': true});
    
        ga('send', 'event', 'Categories', 'Hysteria', pageTitle, {'nonInteraction': true});
    
        ga('send', 'event', 'Categories', 'Music', pageTitle, {'nonInteraction': true});
    
        ga('send', 'event', 'Categories', 'U.S.A.!!!', pageTitle, {'nonInteraction': true});
      
    } else {
        alert('Category Goes Here');    
    }
    
    

    // Check the location and track user
    function trackLocation() {
        bottom = $(window).height() + $(window).scrollTop();
        height = $(document).height();

        // If user starts to scroll send an event
        if (bottom > readerLocation && !scroller) {
            currentTime = new Date();
            scrollStart = currentTime.getTime();
            timeToScroll = Math.round((scrollStart - beginning) / 1000);
            if (!debugMode) {
                ga('send', 'event', 'Reading', 'StartReading', pageTitle, timeToScroll, {'metric1' : timeToScroll});
            } else {
                alert('started reading ' + timeToScroll);
            }
            scroller = true;
        }

        // If user has hit the bottom of the content send an event
        if (bottom >= $('.entry').scrollTop() + $('.entry').innerHeight() && !endContent) {
            currentTime = new Date();
            contentScrollEnd = currentTime.getTime();
            timeToContentEnd = Math.round((contentScrollEnd - scrollStart) / 1000);
            if (!debugMode) {
                 if (timeToContentEnd < 60) {
                    ga('set', 'dimension1', 'Scanner'); 
                } else {
                    ga('set', 'dimension1', 'Reader'); 
                }
                ga('send', 'event', 'Reading', 'ContentBottom', pageTitle, timeToContentEnd, {'metric2' : timeToContentEnd});
            } else {
                alert('end content section '+timeToContentEnd);
            }
            endContent = true;
        }

        // If user has hit the bottom of page send an event
        if (bottom >= height && !didComplete) {
            currentTime = new Date();
            end = currentTime.getTime();
            totalTime = Math.round((end - scrollStart) / 1000);
            if (!debugMode) {
                ga('send', 'event', 'Reading', 'PageBottom', pageTitle, totalTime, {'metric3' : totalTime});
            } else {
                alert('bottom of page '+totalTime);
            }
            didComplete = true;
        }
    }

    // Track the scrolling and track location
    $(window).scroll(function() {
        if (timer) {clearTimeout(timer);}

        // Use a buffer so we don't call trackLocation too often.
        timer = setTimeout(trackLocation, callBackTime);
    });

});
				</script>
<div class="entry"><div class="entry_inner">
<p>&nbsp;</p>
<div id="disqus_thread"></div>
<script>
					    var disqus_config = function () {
					        this.page.url = 'https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh';  
					        this.page.identifier = 'dangerminds_24943'; 
					    };
					    
					    (function() {  
					        var d = document, s = d.createElement('script');
					        
					        s.src = '//dangerminds.disqus.com/embed.js';  					        
					        s.setAttribute('data-timestamp', +new Date());
					        (d.head || d.body).appendChild(s);
					    })();
					</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>
<a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
</div></div>
<div class="paginate">
<p><a href="https://dangerousminds.net/">&lt;&lt; Back to main</a></p>
</div>
</div> 

<script>
		var pwidget_config = {
			copypaste: false,
			shareQuote: true,
			defaults: {
				sharePopups: true,
				gaTrackSocialInteractions: true,
				afterShareText: 'Thanks for sharing our post.',
				hidePopupDelay: 2500,
				services: {
					twitter: {
						via: 'DangerMindsBlog'
					}
				}
			}
		};
	
		(function () {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.async = true;
			s.src = ('https:' == document.location.protocol ? 'https://s' : 'http://i')
			+ '.po.st/share/script/post-widget.js#publisherKey=4cq3jlah43mijd50k40t';
			var x = document.getElementsByTagName('script')[0];
			x.parentNode.insertBefore(s, x);
		})();
		var counters = document.getElementsByClassName('pw-box-counter-fix');
		for (var i = 0, n = counters.length; i < n; i++) {
			var element = counters[i],
			XHR = new XMLHttpRequest();
			element.innerHTML = 'unknown';
			XHR.onreadystatechange =  (function(e) {
				var el = e;
				return function(){
					if (this.readyState == 4 && this.status == 200) {
						el.innerHTML = friendlyExpress(
							JSON.parse(this.responseText).shares
						);
					// if(el.innerHTML = 'NaN') el.innerHTML = '0';
					}
				}
			})(element);
			XHR.open(
				'GET', 
				'http://graph.facebook.com/' + counters[i].parentNode.parentNode.attributes['data-url'].value,
				/*async*/true);
			XHR.send();
			}
			function friendlyExpress(x, legend, power) {
				legend = ' kmbtg';
			power |= 1024;
			var powerLimit = legend.length - 1,
			powerIndex = 0;
			while (x > (power - 1) && powerIndex < powerLimit) {
				x /= power;
				powerIndex++;
			}
			return Math.round(x) + legend[powerIndex];
		}
		</script>

 <div id="sidebar">
<div id="sidead">
<div style="margin-bottom:20px;">
<div id="Desktop_Sidebar_1">
<script>
googletag.cmd.push(function() {googletag.display('Desktop_Sidebar_1');});
</script>
</div>
<div id="Mobile_MedRec_1">
<script>
googletag.cmd.push(function() {googletag.display('Mobile_MedRec_1');});
</script>
</div>
</div>
</div>
<div id="sidebox">
<div id="featuredside"><span>FEATURED ARTICLES</span></div>
<ul>
<li><a href="https://dangerousminds.net/comments/heavy_metal_parking_lot_photos_of_ac_dc_hanging_with_a_bunch_of_teenage_sup" alt="Heavy Metal Parking Lot: Photos of AC/DC hanging with a bunch of teenage super-fans in 1979 | Dangerous Minds" class="feat-side">Heavy Metal Parking Lot: Photos of AC/DC hanging with a bunch of teenage super-fans in 1979</a></li>
<li><a href="https://dangerousminds.net/comments/when_bowie_got_busted_local_news_reports_from_his_iggys_1976_arrest_for_nea" alt="When Bowie got busted: Local news reports from his &amp; Iggy&#8217;s 1976 arrest for nearly a pound of weed | Dangerous Minds" class="feat-side">When Bowie got busted: Local news reports from his &amp; Iggy&#8217;s 1976 arrest for nearly a pound of weed</a></li>
<li><a href="https://dangerousminds.net/comments/astonishing_illustrations_from_the_set_of_kubricks_2001_a_space_odyssey" alt="Astonishing illustrations from the set of Kubrick&#8217;s &#8216;2001: A Space Odyssey&#8217; | Dangerous Minds" class="feat-side">Astonishing illustrations from the set of Kubrick&#8217;s &#8216;2001: A Space Odyssey&#8217;</a></li>
<li><a href="https://dangerousminds.net/comments/polaroids_from_return_of_the_jedi" alt="Polaroids from &#8216;Return of the Jedi&#8217; | Dangerous Minds" class="feat-side">Polaroids from &#8216;Return of the Jedi&#8217;</a></li>
<li><a href="https://dangerousminds.net/comments/what_if_all_the_great_american_punk_heroes_had_their_own_classic_comic_book" alt="What if all the great American punk heroes had their own classic comic book titles? | Dangerous Minds" class="feat-side">What if all the great American punk heroes had their own classic comic book titles?</a></li>
<li><a href="https://dangerousminds.net/comments/innocence_despair_1970s_school_children_sing_bowie_beach_boys_beatles_and_e" alt="Innocence &amp; Despair: 1970s school children sing Bowie, Beach Boys, Beatles and Eagles | Dangerous Minds" class="feat-side">Innocence &amp; Despair: 1970s school children sing Bowie, Beach Boys, Beatles and Eagles</a></li>
<li><a href="https://dangerousminds.net/comments/yep._naked_pendulum_dance_just_about_sums_this_one_up._must-see" alt="Yep. &#8216;Naked Pendulum Dance&#8217; just about sums this one up. Must-see. | Dangerous Minds" class="feat-side">Yep. &#8216;Naked Pendulum Dance&#8217; just about sums this one up. Must-see.</a></li>
</ul>
</div>
<div id="sidead2">

<div id='Desktop_Sidebar_2'>
<script type='text/javascript'>
    googletag.cmd.push(function() {googletag.display('Desktop_Sidebar_2');});
  </script>
</div>

</div>
<div class="fb-page" data-href="https://www.facebook.com/Dangerous-Minds-101990813189245" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"></div>
<div id="addspace"></div>
<div id="sidead3">


</div>
<div id="addspace"></div>

<div class="OUTBRAIN" data-src="https://dangerousminds.net/comments/mad_man_in_waco_the_haunting_rock_ballads_of_waco_cult_leader_david_koresh" data-widget-id="TS_1" data-ob-template="DangerousMinds"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>

</div>
<br class="spacer" />
<div class="footer">
<span>
&copy;2018 Dangerous Minds | <a href="https://dangerousminds.net/privacy-policy" alt="Privacy Policy" class="privacy">Privacy Policy</a>
</span>
</div>
</div> 
<script src="https://dangerousminds.net/assets/js/event_tracking.js"></script>
<script>
	jQuery(function($) {
	  $.universalAnalytics(); // activate all tracking
	});
</script>
<script>
	var domain = window.location.hostname;
	domain = domain.substring(domain.indexOf('.') + 1);
	var not = '[href*="' + domain + '"]';
	$("a[href^='http']").not(not).attr('target','_blank');
</script>

<img src="https://ib.adnxs.com/seg?add=1579131&t=2" width="1" height="1" />

<script language="JavaScript">
var zflag_nid="2057"; var zflag_pbnw="2057"; var zflag_6="5782"; var zflag_sid="1"; var zflag_width="728"; var zflag_height="90"; var zflag_sz="14"; var zflag_$="1442368"; var zflag_pbad="1442368"; 
</script>
<script type="text/javascript" src="https://dangerousminds.net/content/js/social-share-kit.js"></script>
<script type="text/javascript">
    SocialShareKit.init({
        reinitialize: true,
        onBeforeOpen: function (el, provider, paramsObj) {
            console.log('SocialShareKit.init');
            if (provider === 'facebook') {
                paramsObj.networkUrl = 'https://www.facebook.com/dialog/share?app_id=' +
                    1701066353475423 + '&display=popup&href=' + paramsObj.shareUrlEncoded();
            }
        }
    });
</script>
<script type="text/javascript" src="https://assets.pinterest.com/js/pinit.js"></script>
<script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="/content/js/jquery.colorbox-min.js?i=1"></script>
<script type="text/javascript" src="/content/js/footer.js?i=1"></script>
<script id="dsq-count-scr" src="https://dangerminds.disqus.com/count.js" async></script>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>

<script>
  qcdata = {} || qcdata;
       (function(){
       var elem = document.createElement('script');
       elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-6EzWtvBV9sFU3";
       elem.async = true;
       elem.type = "text/javascript";
       var scpt = document.getElementsByTagName('script')[0];
       scpt.parentNode.insertBefore(elem,scpt);
     }());
</script>
<noscript>
<img src="//pixel.quantserve.com/pixel/p-6EzWtvBV9sFU3.gif?" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>


<div id="GumGumFooter">
<script>
    googletag.cmd.push(function() {googletag.display('GumGumFooter');})
  </script>
</div>
</body>
</html>